Status
Contact Support
Back to Ghost
Network status
Incident history
Contact Support
Help center
Back to Ghost
Reduced performance for email analytics
Incident Report for
Ghost
Resolved
This incident has been resolved.
Posted
11
months ago.
Mar
27
,
2024
-
13:47
UTC
Update
A fix has been implemented and we are monitoring the results.
Posted
11
months ago.
Mar
27
,
2024
-
13:02
UTC
Monitoring
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted
11
months ago.
Mar
27
,
2024
-
12:57
UTC
Investigating
Some users may see delays with email analytics due to issues with an upstream provider.
Posted
11
months ago.
Mar
27
,
2024
-
11:37
UTC
This incident affected: Email Delivery (Analytics).
×
Subscribe to Incident
Subscribe to updates for
Reduced performance for email analytics
via . You'll receive .