Maintenance on my.ghost.org and count.ghost.org
Incident Report for Ghost
Resolved
The maintenance is complete
Posted about 1 month ago. Jul 16, 2019 - 17:31 BST
Identified
These services are currently offline for maintenance and will be back shortly.
Posted about 1 month ago. Jul 16, 2019 - 17:12 BST
This incident affected: Ghost.org.