Status
Contact Support
Back to Ghost
Network status
Incident history
Contact Support
Help center
Back to Ghost
Outage on Ghost(Pro)
Incident Report for
Ghost
Resolved
This incident has been resolved.
Posted
5
months ago.
Sep
21
,
2024
-
19:17
UTC
Identified
Some customers are experiencing pages not loading on their site.
We have identified the issue with an upstream provider and working with them to resolve the issue
Posted
5
months ago.
Sep
21
,
2024
-
19:16
UTC
This incident affected: Ghost(Pro).
×
Subscribe to Incident
Subscribe to updates for
Outage on Ghost(Pro)
via . You'll receive .