Status
Contact Support
Back to Ghost
Network status
Incident history
Contact Support
Help center
Back to Ghost
Outage on Ghost(Pro)
Incident Report for
Ghost
Resolved
This incident has been resolved.
Posted
3
months ago.
Nov
04
,
2024
-
00:51
UTC
Update
Signups for Ghost(Pro) are continuing to fail or be slower than expected. We are currently working on a fix.
Posted
3
months ago.
Nov
03
,
2024
-
23:30
UTC
Identified
For the last hour we've been continuing to see billing and signup issues. We've identified the problem and continuing to investigate.
Posted
3
months ago.
Nov
03
,
2024
-
23:06
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
3
months ago.
Nov
03
,
2024
-
21:57
UTC
Investigating
We are investigating the cause of an outage. We will update as soon as we have more info
Posted
3
months ago.
Nov
03
,
2024
-
21:01
UTC
This incident affected: Ghost(Pro).
×
Subscribe to Incident
Subscribe to updates for
Outage on Ghost(Pro)
via . You'll receive .