Reduced performance for email delivery and analytics
Incident Report for Ghost
Resolved
Our upstream provider has mitigated the current issue and restored API access.
Posted Feb 13, 2024 - 03:35 GMT
Update
Our upstream provider continues to experience issues. Some users may see delays with email delivery and analytics. We are continuing to monitor the situation and will to share periodic updates when available.
Posted Feb 13, 2024 - 00:49 GMT
Identified
Our upstream provider continues to experience issues. Some users may see delays with email delivery and analytics. We are actively monitoring the situation and will continue to share periodic updates.
Posted Feb 12, 2024 - 21:35 GMT
Investigating
Some users may see delays with email delivery and analytics due to issues with an upstream provider.
Posted Feb 12, 2024 - 17:29 GMT
This incident affected: Email Delivery (Delivery, Analytics).