Status
Contact Support
Back to Ghost
Network status
Incident history
Contact Support
Help center
Back to Ghost
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Reduced performance for email analytics
Incident Report for
Ghost
Resolved
Our upstream provider has mitigated the issue, so email sending and analytics is operational.
Posted
May
27
,
2024
-
14:04
UTC
Monitoring
Some users may see delays with email analytics due to issues with an upstream provider.
Posted
May
27
,
2024
-
13:42
UTC
This incident affected: Email Delivery (Delivery, Analytics).
×
Subscribe to Incident
Subscribe to updates for
Reduced performance for email analytics
via . You'll receive .