Problems creating new blogs
Incident Report for Ghost
Resolved
Blog creation has been restored for several hours now, along with a fix to ensure this particular failure can't happen again in future.
Posted Jul 23, 2014 - 08:05 BST
Investigating
Several customers have reported being unable to create a new blog. We are investigating the cause of this issue. Existing blogs are not affected.
Posted Jul 23, 2014 - 02:22 BST