Issue with Marketplace Submissions
Incident Report for Ghost
Resolved
A troublesome cache has been duly placed in the naughty corner and all is back to normal.
Posted Dec 11, 2013 - 16:48 GMT
Investigating
We are looking into an issue with submissions to the Ghost Marketplace which are currently failing.
Posted Dec 11, 2013 - 10:06 GMT