Status
Contact Support
Back to Ghost
Network status
Incident history
Contact Support
Help center
Back to Ghost
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Reduced performance for email delivery & analytics
Incident Report for
Ghost
Resolved
This incident has been resolved.
Posted
May
27
,
2024
-
17:54
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
May
27
,
2024
-
16:21
UTC
Investigating
Some users may see delays with email delivery & analytics due to issues with an upstream provider.
Posted
May
27
,
2024
-
15:31
UTC
This incident affected: Email Delivery (Delivery, Analytics).
×
Subscribe to Incident
Subscribe to updates for
Reduced performance for email delivery & analytics
via . You'll receive .