Intermittent issues with signups on Ghost.org
Incident Report for Ghost
Resolved
This incident has been resolved.
Posted Dec 15, 2022 - 02:56 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2022 - 02:23 GMT
Investigating
Some users are currently experiencing difficulties signing up for Ghost(Pro). We are looking into this issue now and hope to have everything back to normal shortly.
Posted Dec 15, 2022 - 02:17 GMT
This incident affected: Ghost(Pro).