Reduced Performance on Ghost(Pro)
Incident Report for Ghost
Resolved
This incident has been resolved.
Posted Mar 07, 2023 - 12:29 GMT
Identified
Some users are currently experiencing difficulties with accessing their sites on Ghost(Pro). We are looking into this issue now and hope to have everything back to normal shortly.
Posted Mar 07, 2023 - 11:54 GMT
This incident affected: Ghost(Pro).