Distributed attack in progress
Incident Report for Ghost
Resolved
This incident has been resolved.
Posted May 30, 2014 - 02:24 BST
Update
Performance has returned to normal. We will continue to monitor for further attacks and improve our infrastructure's handling of them.
Posted May 30, 2014 - 02:24 BST
Investigating
We are currently investigating a distributed attack to the Ghost network which is causing some minor degraded performance to Ghost.org and Ghost(Pro).
Posted May 30, 2014 - 00:39 BST