Degraded Service
Incident Report for Ghost
Resolved
This issue is resolved
Posted Jan 07, 2021 - 20:07 GMT
Investigating
We are currently investigating this issue.
Posted Jan 07, 2021 - 19:40 GMT
This incident affected: Ghost(Pro).