Status
Contact Support
Back to Ghost
Network status
Incident history
Contact Support
Help center
Back to Ghost
Reduced performance for email sending & analytics
Incident Report for
Ghost
Resolved
This incident has been resolved.
Posted
2
years ago.
Feb
22
,
2023
-
12:00
UTC
Monitoring
Our upstream provider is recovering from DDoS attack. We are currently not seeing any more delays to email delivery.
Posted
2
years ago.
Feb
21
,
2023
-
19:34
UTC
Identified
Some users may see delays with email delivery and analytics due to issues with an upstream provider.
Posted
2
years ago.
Feb
21
,
2023
-
10:58
UTC
This incident affected: Email Delivery (Delivery, Analytics).
×
Subscribe to Incident
Subscribe to updates for
Reduced performance for email sending & analytics
via . You'll receive .