Reduced Performance on Ghost(Pro)
Incident Report for Ghost
Resolved
This incident has been resolved.
Posted May 16, 2024 - 13:13 BST
Identified
Some users are currently experiencing difficulties with accessing and logging into their sites on Ghost(Pro). We are looking into this issue now and hope to have everything back to normal shortly.
Posted May 16, 2024 - 11:27 BST
This incident affected: Ghost(Pro).