Degraded performance for Ghost Admin

Incident Report for Ghost

Resolved

All admin panels are performing normally and there are no further issues.
Posted 14 days ago. Jun 12, 2025 - 08:35 UTC

Monitoring

A fix has been rolled out to block some malicious traffic and admin performance is back normal. We're continuing to monitor to make sure it stays that way.
Posted 14 days ago. Jun 12, 2025 - 08:24 UTC

Identified

Some customers are currently experiencing slow loading Ghost admin panels. Our team has identified the issue and is working on a fix.
Posted 14 days ago. Jun 12, 2025 - 08:18 UTC
This incident affected: Ghost(Pro).