Investigating my.ghost.org outage
Incident Report for Ghost
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 17, 2019 - 19:37 BST
Investigating
We are currently investigating degraded performance on my.ghost.org
Posted about 1 month ago. Jul 17, 2019 - 16:00 BST
This incident affected: Ghost.org.