Degraded performance in North America
Incident Report for Ghost
Resolved
Our upstream provider has marked this issue as resolved.
Posted Oct 02, 2014 - 17:06 BST
Monitoring
We are currently monitoring an upstream network issue in North America which is causing slow performance and timeouts for some users. This issue began at 8:30am PST and is currently being investigated by our upstream provider. We will update as we get more information.
Posted Oct 02, 2014 - 16:54 BST