Some regions experiencing degraded performance
Incident Report for Ghost
Resolved
Cloudflare have now marked this issue as resolved.
Posted Jun 29, 2014 - 22:40 BST
Identified
Some European regions are experiencing degraded performance across Ghost.org and the Ghost(Pro) blogs. This is due to degraded performance on the CloudFlare network. We are actively monitoring the situation: https://www.cloudflare.com/system-status
Posted Jun 29, 2014 - 21:00 BST