Ghost.org Down
Incident Report for Ghost
Resolved
A brief connectivity issue at our data centre has been resolved and we do not anticipate any more problems.
Posted May 25, 2015 - 20:35 BST
Monitoring
Ghost.org is back online and we're investigating what caused the outage + monitoring for any further problems.
Posted May 25, 2015 - 19:55 BST
Investigating
We're currently investigating unplanned downtime on Ghost.org
Posted May 25, 2015 - 19:43 BST